Monday, July 13, 2009

The base class includes the field 'ReportViewer1', but its type (Microsoft.Reporting.WebForms.ReportViewer) is not compatible with the type of control (Microsoft.Reporting.WebForms.ReportViewer)

If you are getting this error while using old reports from your legacy application then you can try out the following solutions

  1. Change in your Web.config all "Microsoft.ReportViewer.WebForms, Version=8.0.0.0,..." to " Microsoft.ReportViewer.WebForms, Version=9.0.0.0,..." and in controls "Register Assembly="Microsoft.ReportViewer.WebForms, Version=8.0.0.0,..." to "Register Assembly="Microsoft.ReportViewer.WebForms, Version=9.0.0.0,..."
  2. Clean your solution and delete the related dll files and then again rebuild the solution.

Generally doing step 1 will resolve the problem as in legacy applications its configured to use Version=8.0.0.0

1 comments :

Anonymous said...

not working

Post a Comment